Mail Deliverability Issues
Incident Report for Checkfront
Resolved
Mail deliverability issues are resolved. Our upstream mail provider has resolved their issues that were impacting the reliability of email notifications being sent out.
Posted 5 months ago. May 24, 2017 - 16:46 PDT
Investigating
We are currently experiencing an intermittent delivery interruption with our upstream email provider. We are monitoring their progress and we hope the service will be restored as soon as possible.

For updates, please visit: https://status.sparkpost.com/?_ga=2.157995327.401147035.1495653420-1579848394.1495651206
Posted 5 months ago. May 24, 2017 - 12:16 PDT