Site Builder may be having issues sending emails sent via the Contact Us page
Incident Report for Checkfront
Resolved
This issue was for an individual account, and was mis-identified as being a service outage. We apologize for the inconvenience.
Posted 4 months ago. Jan 09, 2018 - 08:43 PST
Investigating
We are currently investigating issues with email deliverability when a customer uses the "Email Us" feature block on the Site Builder Contact Us page.
Posted 4 months ago. Jan 09, 2018 - 04:01 PST