Service provider issues
Incident Report for Checkfront
Resolved
Google Cloud seems to have rectified the problem, however we will continue to monitor the situation.
Posted about 1 year ago. Oct 17, 2016 - 11:44 PDT
Investigating
Google Cloud appears to be expericing issues, leading to downtime for some of our servers. More information will be posted as Google provides it.
Posted about 1 year ago. Oct 17, 2016 - 11:42 PDT